Topic Options
#3192 - 12/02/17 04:37 AM Please help interpreting my results
StealthKid41 Offline


Registered: 12/02/17
Posts: 3
Hello!

Long story short I'm fighting with my ISP for a long time now but they can't see the issue I'm having even when I've provided them pingplotter reports.

I would like to ask for some help interpeting my resutls to see if I was mistaken, or the ISP is the one who doesn't know what they are doing.

I've attached two pictures which I need help with. First hop is the home gateway, the second one is the CMTS of the ISP. No matter what I ping the packet loss starts to show up starting the second hop. Is it even a packet loss? In the bottom graph it always shows up as a 100% packet loss, so could it be that the internet is cutting off for random periods of times somewhere between the HGW and the CMTS?

Please someone help me telling what could be the problem because it makes my internet unusable and my ISP doesn't want to acknowledge that the problem is there.

Edit: I've added a sample set from today in the hopes that it might be easier to find where the issue is.


Attachments
201712018.png (39 downloads)
201712019.png (33 downloads)
www.index.hu.pp2 (81 downloads)



Edited by StealthKid41 (12/02/17 10:16 AM)

Top
#3193 - 12/03/17 05:58 PM Re: Please help interpreting my results [Re: StealthKid41]
Hayla Offline

Pingman Staff


Registered: 10/16/17
Posts: 31
Hey there,

Thanks for writing to us!

I think your case is definitely compelling, and I do see what you're referring to with the extensive packet loss. However, I don't have *quite* enough information to be able to help decipher.

What I'd recommend is trying just a few different options to see the impact. While it does appear that the ISPs router may be the source of much packet loss (telling by the replicated pattern and extensive packet loss carrying through each subsequent hop), it would be helpful if you could leave a consistent trace going to a reliable service (24x7 is helpful, and I always personally recommend a simple Google trace). From here, when you notice an issue, make a note of it, and head back to PingPlotter to try and correlate the PingPlotter data with the symptoms you experienced. Find the packet loss pattern, and try to correlate it with the earliest pattern you can. Here's an article that might articulate this information a bit better than I do:

https://www.pingplotter.com/fix-your-network/interpret-results.html

It does appear that this could get a bit messy, given the results I've seen from your sample set, but see if that helps in interpreting where exactly your issue is.

I'd also like to add, it may prove helpful to alter the packet types PingPlotter is sending to mimic that of normal network traffic. If you'd like to try this out, make sure you have WinPcap installed (this will allow PingPlotter to actually generate these types of packets). If you don't have it, here's a link to their download site:

https://www.winpcap.org/install/

Now, within PingPlotter, if you head to Edit -> Options -> Engine (or Packet, depending on your edition), you can change the packet type to TCP, and use port 80 to mimic normal web traffic. Go ahead and leave that running for quite some time (24x7 is best, as aforementioned, as the more data you have, the more compelling your case). When you do this, do you get similar results to your prior traces? If so, can you narrow the origination of packet loss down to one or two culprit hops?

If you'd like us to take a closer look as you gather more information, feel free to submit a support ticket to us by heading to Help -> Email PingPlotter Support. Either that, or you can send a sample set of an extensive amount of time (maybe around 3 hours or more) to support@pingman.com. We'd love to take a look! If the file turns out to be too big to email, go ahead and submit the support ticket from within the program and we can create a secure Dropbox link to grab that file from you.

Let me know if this was helpful, or if any additional information would be better!
_________________________
Regards,
Hayla

Top
#3257 - 05/28/18 04:23 AM Re: Please help interpreting my results [Re: Hayla]
StealthKid41 Offline


Registered: 12/02/17
Posts: 3
Well, hello again!

First of all, sorry to necro my thread but I'm still having issues.

The situation changed and currently I'm only having packet losses at nighttime anywhere between 8-11 PM almost every day. The length of the packet loss period is variable, it's usually between 1 and 2 hours and it can be experienced on all devices connected to the HGW.

After I got an e-mail back from you I've contacted my ISP again to fix this issue. Since then they've changed the coax coming from the electric pole to our HGW to see if that caused the issue, and started monitoring the connection to the HGW for 10 days.

Sadly that didn't fix the issue either. I've phoned back and they've sent out another technician to check on my PC. He created a new doubleword named IGMPLevel in regedit, saying that the HGW has some issues with the Windows 10 multicast and that's causing the packet loss. I highly doubt it since I had the same packet loss issue since last year, even before the ISP changed the HGW for a newer model. Of course that wasn't the problem, the packet loss can be still experienced.

I showed him my pingplotter reports too, explained where the issue might be, but I got shot down, because he said "this software isn't accurate". I've asked him if they've seen anything in the monitoring, for which he said they've seen some packet losses, but it shouldn't negatively impact the usage of internet.

It's a nice joke, in online games I still lose control of my characters, get warnings that there is an issue with my connection, I will disconnect in 30 seconds, and the serverside crosshair is lagging behind the clientside one, while my ping is in the 30's, Skype call quality goes down when I have a call at packetloss times.

Next day I got a nice SMS from the ISP that they don't have any problem with the line and I should call their PC technicians who would gladly fix my PC for a good sum of money, since the problem is on my end.

Why should the problem be on my side when the packet loss still starts at the second hop in Pingplotter and in WinMTP too, which is the CMTS? If the problem is on my side, how come the issue can't be always experienced, only at nighttime? How come there are some nights when everything is fine and I have no packet loss?

I've tried connecting the devices one by one each one after 15 minutes to the HGW while monitoring the connection with pingplotter. I couldn't see any packet loss that way. The only other thing I could think of was that the HGW was overheating, but it was in an open space so the air could move around it. It's not even overloaded, 2 PCs and 1 IPTV box are connected via Ethernet, and 2 mobiles via WiFi. Yesterday I've tried putting a fan next to it and blowing air onto it, but I've still got the packet loss.

If needed, I can send some of the reports saved on my PC your way again.

Top
#3261 - 06/07/18 04:29 PM Re: Please help interpreting my results [Re: StealthKid41]
Hayla Offline

Pingman Staff


Registered: 10/16/17
Posts: 31
Hey StealthKid!

Sorry it's taken me a week to see your post. I usually try to be speedy, but apparently this was not my week.

I looked at your data again, and purely off of the quantitative data, I see a lot of issues starting at hop 2, repeatedly. Now, this data set is from December, but I do stand by what I said. PingPlotter uses a combination of your plain ol' ping and traceroute to deliver results in a graphical way - so if you just had a ping -t going to your final hop, I'd bet my bank account you'll see the same thing as PingPlotter (except ugly, because... command is ugly. That's why we made PingPlotter to begin with).

If you want to send over some data, you can - but I'd save my breath on that one. If you have a data set that looks like the one sent over in December, it's likely the same issue - and I'd encourage you to compare your patterns to these when talking to the ISP:

https://www.pingplotter.com/fix-your-network/common-network-problems

I'm really sorry that your ISP doubts the software - I'm glad to see that you've still got faith, and I hope we can make a good impression on your ISP here. If you want, you can send over our reviews from customers on Capterra and Spiceworks, along with your data.

https://www.capterra.com/p/143523/PingPlotter/
https://community.spiceworks.com/products/3275-pingman-tools-pingplotter

At this point, it really seems like you've got a grasp on PingPlotter - the struggle now is going to be convincing your ISP that you need some help on your link. Let us know if you need any additional help - but at this point, it looks like you've used it pretty effectively. From one PingPlotter user to another, BRAVO!
_________________________
Regards,
Hayla

Top
#3262 - 06/08/18 05:38 AM Re: Please help interpreting my results [Re: Hayla]
StealthKid41 Offline


Registered: 12/02/17
Posts: 3
Thanks for getting back to me!

I get similar results to the December one, but not as severe as it was before and it's limited to the timespan mentioned in my previous post.

You are right about the ping command. I've pinged my HGW and the end destination at the same time, the HGW still showed 0 lost packets, but I got the packetloss at the end destination. Tried the tracert and pathping commands too and those showed similar results.

I've checked the patterns you linked to me and in my opinion it still looks like it's the "Internet Service Provider Bad Hardware" issue, since the issue starts at hop 2 and goes all the way to the designation.

I guess my ISP just doesn't care. I don't really want to "complain" to them about this again, they didn't fix it for 8 months, doubt they would ever fix it properly and I'm pretty sure they had enough of me, because I've called them about this issue for like 20 times over the past 8 months. Also they told me that the issue is on my side, I'm afraid if I push them more they will just cut off the line and I will have to pay them since we ended the service before the end date in the agreement.


Edited by StealthKid41 (06/08/18 05:42 AM)
Edit Reason: Typo

Top

Search

Who's Online
0 registered (), 5 Guests and 0 Spiders online.
Key: Admin, Global Mod, Mod